WordPress Vulnerability Report – May 25, 2022


Warning: getimagesize(https://ps.w.org/minimal-coming-soon-maintenance-mode/assets/banner-1544x500.png?rev=1807800): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/official-mailerlite-sign-up-forms/assets/banner-1544x500.png?rev=2657193): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/kivicare-clinic-management-system/assets/banner-772%C3%97250.jpg?rev=2404604): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/zephyr-project-manager/assets/banner-772x250.png?rev=1934187): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/popup-box/assets/banner-772x250.png?rev=2540595): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/keep-backup-daily/assets/banner-1544x500.png?rev=2548175): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/filr-protection/assets/banner-1544x500.png?rev=2280020): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Vulnerable plugins and themes are the #1 reason WordPress websites get hacked. The weekly WordPress Vulnerability Report powered by WPScan covers recent WordPress plugin, theme, and core vulnerabilities, and what to do if you run one of the vulnerable plugins or themes on your website.

Each vulnerability will have a severity rating of low, medium, high, or critical. Responsible disclosure and reporting of vulnerabilities is an integral part of keeping the WordPress community safe. Please share this post with your friends to help get the word out and make WordPress safer for everyone!

WordPress Core Vulnerabilities

WordPress 6.0 “Arturo” is out! This major version release of WordPress was “built to help you unlock your creative aspirations and make your site-building experience more intuitive,” including almost 1,000 enhancements and bug fixes. See what’s new in WordPress 6.0.

  • No new WordPress core vulnerabilities were disclosed this week.

WordPress Plugin Vulnerabilities

In this section, the latest WordPress plugin vulnerabilities have been disclosed. Each plugin listing includes the type of vulnerability, the active installations, the version number if patched, and the severity rating.

Google Tag Manager for WordPress

Product image for GTM4WP.

Plugin
GTM4WP
The vulnerability has been patched, so you should update to version 1.15.1.

Minimal Coming Soon – Coming Soon Page

Product image for Minimal Coming Soon – Coming Soon Page.

Vulnerability
Multiple Authenticated Stored XSS
The vulnerability has been patched, so you should update to version 2.35.

JupiterX Core

Vulnerability
Information Disclosure, Modification, and Denial of Service; Subscriber+ Arbitrary Plugin Deactivation and Settings Update; Subscriber+ Privilege Escalation and Post Deletion
The vulnerability has been patched, so you should update to version 2.0.7.

Simple Membership

Product image for Simple Membership.

The vulnerability has been patched, so you should update to version 4.1.1.

Zephyr Project Manager

Product image for Zephyr Project Manager.

The vulnerability has been patched, so you should update to version 3.2.41.

Keep Backup Daily

Product image for Keep Backup Daily.

The vulnerability has been patched, so you should update to version 2.0.3.

Google Places Review

Vulnerability
Admin+ Stored Cross Site Scripting
The vulnerability has been patched, so you should update to version 2.0.0.

Slideshow CK

Vulnerability
Admin+ Stored Cross-Site Scripting
The vulnerability has been patched, so you should update to version 1.4.10.

The School Management

Vulnerability
Unauthenticated RCE via REST api
The vulnerability has been patched, so you should update to version 9.9.7.

WordPress Plugin Vulnerabilities – No Known Fix

This section contains plugin vulnerabilities with no known fix. Until a patch is available, immediately uninstall and delete the plugin.

iQ Block Country

Vulnerability
Protection Bypass due to IP Spoofing
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Code Snippets Extended

Vulnerability
Stored Cross-Site Scripting via CSRF; Arbitrary Snippet Deletion/Disabling via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Webriti SMTP Mail

Vulnerability
Arbitrary Settings Update via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Change Uploaded File Permissions

Vulnerability
File Permission Update via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

New User Email Set Up

Vulnerability
Arbitrary Settings Update via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

RB Internal Links

Vulnerability
Stored Cross-Site Scripting via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

postTabs

Plugin
postTabs
Vulnerability
Arbitrary Settings Update via CSRF to Stored XSS
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Private Files

Plugin
Private Files
Vulnerability
Protection Disabling via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

WP Athletics

Plugin
WP Athletics
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Advanced Admin Search

Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

WP-chgFontSize

Vulnerability
Arbitrary Settings Update via CSRF to Stored XSS
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Latest Tweets Widget

Vulnerability
Arbitrary Settings Update via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

WP Admin Style

Vulnerability
Admin+ Stored Cross-Site Scripting
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Opal Hotel Room Booking

Vulnerability
Contributor+ Stored Cross-Site Scripting
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Genki Pre-Publish Reminder

Vulnerability
Stored XSS & RCE via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Enqueue Anything

Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Carousel CK

Plugin
Carousel CK
Vulnerability
Admin+ Stored Cross-Site Scripting
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Auto Delete Posts

Vulnerability
Arbitrary Settings Update via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

LaTeX for WordPress

Vulnerability
Arbitrary Settings Update via CSRF to Stored XSS
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

One Click Plugin Updater

Vulnerability
Arbitrary Settings Update via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Member Hero

Plugin
Member Hero
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Log WP_Mail

Plugin
Log WP_Mail
Vulnerability
Email Logs Publicly Accessible
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Sideblog

Vulnerability
Arbitrary Settings Update via CSRF to Stored XSS
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Bestbooks

Plugin
Bestbooks
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Static Page eXtended

Vulnerability
Arbitrary Settings Update via CSRF to Stored XSS
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.
Vulnerability
Arbitrary Settings Update via CSRF to Stored XSS
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Sticky Popup

Plugin
Sticky Popup
Vulnerability
Admin+ Stored Cross-Site Scripting
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Email Users

Plugin
Email Users
Vulnerability
Arbitrary Settings Update via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

WP SVG Icons

Plugin
WP SVG Icons
Vulnerability
Admin+ Remote Code Execution (RCE)
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Peter’s Collaboration E-mails

Vulnerability
Arbitrary Settings Update via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Useful Banner Manager

Vulnerability
Modify banners via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

OnePress Social Locker

Vulnerability
Arbitrary Settings Update via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Core Control

Plugin
Core Control
Vulnerability
Arbitrary Settings Update via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

HC Custom WP-Admin URL

Vulnerability
Arbitrary Settings Update via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

Hot Linked Image Cacher

Vulnerability
Image upload/cache abuse via CSRF
Patched in Version
No Fix
The vulnerability has not been patched and the plugin is closed. You should uninstall and delete the plugin.

WordPress Theme Vulnerabilities

In this section, the latest WordPress theme vulnerabilities have been disclosed. Each theme listing includes the type of vulnerability, the active installations, the version number if patched, and the severity rating.

Jupiter & JupiterX

Vulnerability
Subscriber+ Path Traversal and Local File Inclusion; Subscriber+ Arbitrary Plugin Deletion; Subscriber+ Privilege Escalation and Post Deletion; Subscriber+ Path Traversal and Local File Inclusion; Subscriber+ Arbitrary Plugin Deactivation and Settings Update
The vulnerability has been patched, so you should update to version 6.10.2.

Never worry about running a vulnerable plugin or theme again.

As you can see from this report, lots of new WordPress plugin and theme vulnerabilities are disclosed each week. We know it can be difficult to stay on top of every reported vulnerability disclosure, so the iThemes Security Pro plugin makes it easy to make sure your site isn’t running a theme, plugin, or WordPress core version with a known vulnerability.

Scans Your Website Twice a Day for Vulnerabilities

Your website’s plugins, themes, and WordPress core versions are checked against the WPScan Vulnerability Database for the latest vulnerability disclosures.

Automatically Updates if a Security Fix is Available

Paired with Version Management, iThemes Security will automatically update a plugin, theme, or WordPress core version if it has a vulnerability.

Emails You if Site Scan Detects a Vulnerability

You can receive an email report if your site is running vulnerable versions of a plugin, theme, or WordPress core. Customize the email addresses that receive scan results.

The Best WordPress Security Plugin to Secure & Protect WordPress Sites

WordPress currently powers over 40% of all websites, so it has become an easy target for hackers with malicious intent. The iThemes Security Pro plugin takes the guesswork out of WordPress security to make it easy to secure & protect your WordPress website. It’s like having a full-time security expert on staff who constantly monitors and protects your WordPress site for you.

The post WordPress Vulnerability Report – May 25, 2022 appeared first on iThemes.

This content was originally published here.