WordPress Vulnerability Report – April 13, 2022


Warning: getimagesize(https://ps.w.org/all-in-one-wp-security-and-firewall/assets/banner-1544x500.png?rev=1914011): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/sg-security/assets/banner-1544x500.jpg?rev=2539990): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/leadin/assets/banner-1544x500.png?rev=2708467): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/visual-form-builder/assets/banner-1544x500.png?rev=1205840): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/adrotate/assets/banner-1544x500.jpg?rev=2308166): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/ad-invalid-click-protector/assets/banner-1544x500.png?rev=2520179): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/sitemap-by-click5/assets/banner-1544x500.png?rev=2339752): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/jc-importer/assets/banner-772x250.png?rev=2660751): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/bp-activity-filter/assets/banner-772x250.jpg?rev=1758126): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/multiple-shipping-address-woocommerce/assets/banner-1544x500.png?rev=2707334): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/bp-user-profile-reviews/assets/banner-772x250.jpg?rev=1780042): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/lock-my-bp/assets/banner-772x250.jpg?rev=1756902): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/fast-flow-dashboard/assets/banner-772x250.jpg?rev=1971317): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Warning: getimagesize(https://ps.w.org/wbcom-designs-buddypress-ads/assets/banner-772x250.jpg?rev=2632631): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/customer/www/kerbco.com/public_html/wp-content/plugins/code-snippets/php/snippet-ops.php(582) : eval()'d code on line 22

Vulnerable plugins and themes are the #1 reason WordPress websites get hacked. The weekly WordPress Vulnerability Report powered by WPScan covers recent WordPress plugin, theme, and core vulnerabilities, and what to do if you run one of the vulnerable plugins or themes on your website.

Each vulnerability will have a severity rating of low, medium, high, or critical. Responsible disclosure and reporting of vulnerabilities is an integral part of keeping the WordPress community safe. Please share this post with your friends to help get the word out and make WordPress safer for everyone!

WordPress Core Vulnerabilities

WordPress 5.9.3 was released on April 5, 2022, as a short-cycle maintenance release with 19 bug fixes. Because this is a core update, be sure to update to WordPress 5.9.3 as soon as possible.

  • No new WordPress core vulnerabilities were disclosed this week.

WordPress Theme Vulnerabilities

n this section, the latest WordPress plugin vulnerabilities have been disclosed. Each plugin listing includes the type of vulnerability, the active installations, the version number if patched, and the severity rating.

All In One WP Security

Product image for All In One WP Security & Firewall.

Plugin
All In One WP Security & Firewall
Vulnerability
Authenticated Arbitrary Redirect / Reflected XSS
The vulnerability has been patched, so you should update to version 4.4.11.

SiteGround Security

Product image for SiteGround Security.

Vulnerability
Authentication Bypass via 2-FA Authentication Setup; Authorization Weakness to Authentication Bypass via 2-FA Back-up Codes
The vulnerability has been patched, so you should update to version 1.2.6.

Photo Gallery

Product image for Photo Gallery by 10Web – Mobile-Friendly Image Gallery.

Plugin
Photo Gallery by 10Web – Mobile-Friendly Image Gallery
Vulnerability
Unauthenticated SQL Injection; Reflected Cross-Site Scripting
The vulnerability has been patched, so you should update to version 1.6.3.

HubSpot

Product image for HubSpot – CRM, Email Marketing, Live Chat, Forms & Analytics.

Plugin
HubSpot – CRM, Email Marketing, Live Chat, Forms & Analytics
The vulnerability has been patched, so you should update to version 8.8.15.

Import and export users and customers

Product image for Import and export users and customers.

Plugin
Import and export users and customers
Vulnerability
Admin+ Stored Cross-Site Scripting
The vulnerability has been patched, so you should update to version 1.19.2.1.

Visual Form Builder

Product image for Visual Form Builder.

Vulnerability
Entries Deletion/Restoration via CSRF; Admin+ Stored Cross-Site Scripting
The vulnerability has been patched, so you should update to version 3.0.8.

Adrotate

Product image for AdRotate – Ad manager & AdSense Ads.

Plugin
AdRotate – Ad manager & AdSense Ads
Vulnerability
Admin+ XSS via Advert Name; Admin+ XSS via Group Name
The vulnerability has been patched, so you should update to version 5.8.23.

Content Egg

Product image for Content Egg.

The vulnerability has been patched, so you should update to version 5.3.0.

Ad Invalid Click Protector (AICP)

Product image for Ad Invalid Click Protector (AICP).

Plugin
Ad Invalid Click Protector (AICP)
Vulnerability
Reflected Cross-Site Scripting; Arbitrary Ban Deletion via CSRF
The vulnerability has been patched, so you should update to version 1.2.7.

Sitemap by click5

Product image for Sitemap by click5.

Vulnerability
Unauthenticated Arbitrary Options Update
The vulnerability has been patched, so you should update to version 1.0.36.

Import WP

Product image for Import WP – Import and Export WordPress data to XML or CSV files.

Plugin
Import WP – Import and Export WordPress data to XML or CSV files
Vulnerability
Admin+ Arbitrary File Upload to RCE
The vulnerability has been patched, so you should update to version 2.4.6.

Wbcom Designs Plugins – BuddyPress Activity Filter

Product image for Wbcom Designs – BuddyPress Activity Filter.

Plugin
Wbcom Designs – BuddyPress Activity Filter
The vulnerability has been patched, so you should update to version 2.8.0.

Multiple Shipping Address Woocommerce

Product image for Multiple Shipping Address Woocommerce.

Plugin
Multiple Shipping Address Woocommerce
The vulnerability has been patched, so you should update to version 2.0.

Wbcom Designs Plugins – BuddyPress Member Reviews

Product image for Wbcom Designs – BuddyPress Member Reviews.

Plugin
Wbcom Designs – BuddyPress Member Reviews
The vulnerability has been patched, so you should update to version 2.7.0.

Wbcom Designs Plugins – Private Community for BuddyPress

Product image for Wbcom Designs – Private Community for BuddyPress.

Plugin
Wbcom Designs – Private Community for BuddyPress
The vulnerability has been patched, so you should update to version 1.7.0.

SiteSuperCharger

The vulnerability has been patched, so you should update to version 5.2.0.

Fast Flow

Product image for Fast Flow.

The vulnerability has been patched, so you should update to version 1.2.11.

Wbcom Designs Plugins – BuddyPress Hashtags

The vulnerability has been patched, so you should update to version 2.7.0.

Wbcom Designs Plugins – BuddyPress Check-ins Pro

The vulnerability has been patched, so you should update to version 1.4.0.

Wbcom Designs Plugins – BuddyPress Sticky Post

The vulnerability has been patched, so you should update to version 1.9.9.

WordPress Plugin Vulnerabilities – No Known Fix

This section contains plugin vulnerabilities with no known fix. Until a patch is available, immediately uninstall and delete the plugin.

Wbcom Designs Plugins – BuddyPress Ads

Product image for Wbcom Designs – BuddyPress Ads.

Plugin
Wbcom Designs – BuddyPress Ads
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Advanced Page Visit Counter

Plugin
Advanced Page Visit Counter – Most Advanced WordPress Visit Counter Plugin
Vulnerability
Unauthenticated Stored Cross-Site Scripting
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Documentor

Plugin
Documentor – Create Product Documentation
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Event List

Vulnerability
Admin+ Stored Cross-Site Scripting
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Tipsacarrier

Vulnerability
Unauthenticated SQLi; Unauthenticated Orders Disclosure
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – BuddyPress Activity Social Share

Plugin
Wbcom Designs – BuddyPress Activity Social Share
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – BuddyPress Create Group Type

Plugin
Wbcom Designs – BuddyPress Create Group Type
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – BuddyPress Group Reviews

Plugin
Wbcom Designs – BuddyPress Group Reviews
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – BuddyPress Job Manager

Plugin
Wbcom Designs – BuddyPress Job Manager
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – BuddyPress Search

Plugin
Wbcom Designs – BuddyPress Search
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – BuddyPress Todo List

Plugin
Wbcom Designs BuddyPress Todo List
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – Check-ins for BuddyPress Activity

Plugin
Wbcom Designs – Check-ins for BuddyPress Activity
Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – Custom Email Options

Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – Custom Font Uploader

Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – Woo Audio Preview

Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – Woo Document Preview

Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

Wbcom Designs Plugins – WordPress System Log

Patched in Version
No Fix
The vulnerability has not been patched. You should deactivate the plugin.

WordPress Theme Vulnerabilities

In this section, the latest WordPress theme vulnerabilities have been disclosed. Each theme listing includes the type of vulnerability, the active installations, the version number if patched, and the severity rating.

  • No new WordPress core vulnerabilities were disclosed this week.

Never worry about running a vulnerable plugin or theme again.

As you can see from this report, lots of new WordPress plugin and theme vulnerabilities are disclosed each week. We know it can be difficult to stay on top of every reported vulnerability disclosure, so the iThemes Security Pro plugin makes it easy to make sure your site isn’t running a theme, plugin, or WordPress core version with a known vulnerability.

The Best WordPress Security Plugin to Secure & Protect WordPress

WordPress currently powers over 40% of all websites, so it has become an easy target for hackers with malicious intent. The iThemes Security Pro plugin takes the guesswork out of WordPress security to make it easy to secure & protect your WordPress website. It’s like having a full-time security expert on staff who constantly monitors and protects your WordPress site for you.

The post WordPress Vulnerability Report – April 13, 2022 appeared first on iThemes.

This content was originally published here.